読者です 読者をやめる 読者になる 読者になる

IX2015からIX2105への入れ替え

概要

EtherIPに利用しているIX2015がFastEtherしかついていないので、IX2105に入れ替えようという試みです。
ついでに速度も測ってみました。

スペック

IX2015

郵便局に使われてたとか噂されるルータ。
ヤフオク等で1k/台と格安で入手可能なことでも知られる。
IPsecアクセラレーションとかついててお得。
FastEtherが3系統(うち1系統はスイッチングハブ
他にもポートがある気がするけど、どうせ使わない。
コンソール接続にはシスコケーブルが必要。

IX2105

Gigabit, VPNに対応しているもののうち安いもの。
現行機種で、売価53,700円(2014/02/04現在)
GigaEtherが2系統(うち1系統はスイッチングハブ
同様に、コンソール接続にはシスコケーブルが必要。
http://jpn.nec.com/univerge/ix/Info/ix2105.html

config作成

基本的なEtherIPの設定のみ載せときます。
以下はaaa.aaa.aaa.aaaのconfig抜粋で、
ポート1から入ってきたデータが、カプセルされポート0から出て行きます。

bridge irb enable
!
interface GigaEthernet0.0
  ip address aaa.aaa.aaa.aaa/aa
  no shutdown
!
interface GigaEthernet1.0
  no ip address
  bridge-group 1
  no shutdown
!
interface BRI0.0
  no ip address
  bridge-group 1
  no shutdown
!
interface Tunnel1.0
  tunnel mode ether-ip ip
  tunnel destination bbb.bbb.bbb.bbb
  tunnel source aaa.aaa.aaa.aaa
  no ip address
  bridge-group 1
  no shutdown

ベンチマーク

環境

共にnetperf 2.6.0
サーバー・クライアント間にはIX2**5の他にいくつかのL2が入る。

サーバー

Express5800/120Rj-2

クライアント

ThinkPad S230u

結果

v4/v6で変わるとは思えないが一応測ったので。

IX2015 < IX2105 <
IPv4 IPv6 IPv4 IPv6
AVE 44.7 Mbps 43.6 Mbps 132.9 Mbps 131.3 Mbps
VAR 1.7E-02 2.0E-01 2.6E-02 1.2E-02

結論

3倍早くなって良かった。

付録

基板の写真貼っておきます。

IX2015


IX2105

ALTERAのFPGA載ってる

サイズ感

右がIX2015、左がIX2105です。
コンパクトになってる